Mazda 6 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
2014 Front suspension popping/clicking noise

I've been to the dealer once on this issue(jan 2014), and about to go again...

When doing low speed (5-7mph) manuevers in parking lots/in ou of driveways, I hear a noise on both front suspention towers. It's a clicking/popping noise, not so much a clunk that I hear as I turn the wheels to go from forward to reverse( as in out of a parking lot spot).

On my 10k mile visit, the service tech couldn't reproduce, and I was in the car and didnt hear it either. He mentioned there's a TSB about some suspension boot/strut top issue that can be fixed. There were no loose bolts, no rips or tears in rubber or boots.

Anyone else with this or similar issue?

I have the same exact issue as you do. I took my 2014 Mazda 6 to the dealer for this issue 2 weeks ago. The technician was able to duplicate the noise and they replaced the Upper strut bearings as per TSB 02 005/13. Unfortunately the bearings did not completely correct the problem. Like many others have said, the noise is mostly at very slow speeds especially while turning. I notice on inclines as well for example steep driveways and speed bumps. I will be taking my car back to the dealer and will update soon.
 

·
Registered
Joined
·
5 Posts
Overall I notice less noise from the struts going over bumps, but the popping/clicking (however people describe the noise) is there still. I thought I had very bad OCD until I read posts from this site. I do agree with others in that it happens more when you first get in the vehicle and it is cold. I have an appointment Monday. I will update with the next TSB...hopefully!!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top