Mazda 6 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Had this happen to me on the way home from work today. Tight traffic on the freeway going about 50 and needed to merge right. Lifted a bit, merged and when I hit the gas, nothing but RPM's. Looked at the shift lever, but still in drive. Started to pull over and just as suddenly it springs back to life. I drove straight to the dealer. While on the way, I checked the manual mode and instead of getting the numbers all that displayed was the M. When I got to the dealer I DIDN'T turn off the car until I showed the tech that the manual mode and paddle shifters weren't working. They looked at the car and while I waited and said they found a code but needed to do a consult with Mazda on it. Really??? Glad I didn't shut of the car initially, because as soon as they restarted the car, it was back to normal. They said to bring it back Monday morning to have them do a complete inspection. So I guess I just pray it lasts til then... Wow... 11000 miles on the clock so it's all under warranty but damn my luck...

Mike
 

·
Registered
Joined
·
17 Posts
Just an update. The code came back relating to an auto transmission valve body. Part will be in tomorrow and fixed by tomorrow afternoon. Still glad I didn't shut off the car when it first happened so they could get the code...
 

·
Registered
Joined
·
17 Posts
Last note from me on this subject. The code that came up was P1738 "Shift Time Error". Mazda told them to replace trans control valve body. PYY3-21-C00A Control Valve.

Hope this helps someone else.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top