Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I've got a UK spec 2011 2.2 Diesel Sport. I think it uses the same Advanced Key, Keyless Entry and Push Button start as the US model so I would be interested to see if anyone has seen this problem

Yesterday I tried to start it but when I depressed the clutch (the clutch is used instead of brake on the manual gearbox) the Start Button / Advanced Key light initially turned green, but then both changed to red as soon as I tried to start it and the car would not start. After that both the start button and the advanced key light would always appear red when trying to start the car.

I tried the spare key, tried replacing batteries in key fobs, tried the backup key/s in the ignition, etc, all to no avail. I could still lock / unlock without any issue.

The breakdown company arrived checked the main car battery but found no issues, they tried disconnecting the battery to reset to no avail, so finally towed me back to Mazda garage.

The Mazda garage got it going with their computer and reset the immobiliser, etc. My parents picked the key up while I was at work so I went to collect it.

I put my foot on the clutch and the Start Button and key light all lit up green! Great I thought, it's fixed, until I tried to start it and both turned red again and now they are red again whenever I press the clutch to try and start it.

It's still at a Mazda garage but they seem confused beyond plugging computer in and resetting the immobiliser. Has anyone come across this before or have any idea what could be triggering it or if there is any way of getting the car started if it happens again as my recovery company start charging for same fault call outs.

Thanks,
Craig
 

·
Registered
Joined
·
1,486 Posts
Will it start with the actual key? If not, it sounds like the clutch safety switch is going out or the piston is bent that indicates the clutch pedal is in and it's safe to start.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thankyou for the reply. The actual key makes no difference and I still get a red start button and red key on the dash.

I'm not sure the clutch is the problem either as the start button and the key light on the dash light up in response to me depressing the clutch, they are just lighting up red instead of green.

It's got Mazda confused.

Thanks,
Craig
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Just a theory, but is there an internal antenna used for the Advanced Key / Immobiliser? If so then if that were to have an issue then the computer would think someone is trying to start the car without the key and lock down.

Does anyone know the location of the internal antenna/s?
 

·
Registered
Joined
·
1,486 Posts
There are several throughout the car. I say the main car battery is toast.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
2 Participants
Chuckie
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top