Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
i keep getting the code p2187 and idk what it could be. it says bank one leak at idle. what would cause this?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #2
anyhelp? intakes throw that code i know but mine went 10 months without a cel and i replaced the filter... so idk what would be doing it
 

·
Registered
Joined
·
585 Posts
Are you sure of the number? I searched my 03 manual and can't find anything close to it? It sounds most like an o2 sensor or something.
 

·
Registered
Joined
·
585 Posts
Google "mazda P2187"
 

·
Registered
Joined
·
101 Posts
Discussion Starter #6
something is trigering the first 02 sensor the get a lean mixture thats what the code is saying. so to much air is going in. but idk where it would be coming from.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #8
accordian tube... hmm im not sure which one that is. im using a k and n intake. i dont believe i use that any more
 

·
Registered
Joined
·
585 Posts
How many miles on your car? Is the car running OK or have a studder? The bank 1 O2 sensor could actually be bad. When did you put on the K&N CAI and when did the trouble start? Does the weather seem to have any effect, hot,cold, windy....?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #12
my car has 52k no the k and n had no effect never through a code so i know its not that. i stored my car all winter so weather shouldnt be an issue. it did just get really hot really fast like from 40s to 100! in a week but i fixed part of my exhaust before the cat and tightened it up and i havnt thrown a code since so maybe there was an exhaust leak... hopefully
 
1 - 12 of 12 Posts
Top