Mazda 6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi

I have a 2006 Mazda 6, with a 3.0L V6 motor and a 6-speed automatic transmission. When I try to accelerate hard, the car shifts hard to 4th, 5th or 6th gear, and sometimes it seems the transmission is slipping, i.e. engine revs but car doesn't accelerate.

I took the car to several shops and dealerships and none of them can figure out the EXACT problem; they only suggest that the transmission should be replaced. And that's a LOT of $$!

I noticed that there is a service bulletin about this issue: http://www.6crew.com/files/tsb/05-016-06-1725.pdf. According to this TSB, it seems to be a problem with the control valve body. I am planning to have it replaced, but will that solve my problem?

Additional info: there is no check engine lights, no AT lights, no codes. Transmission fluid is not burnt, doesn't have metal debris (I think), and level is OK. The problem does not occur every time; it happens more when going uphill.

More questions:
1. Has anyone had the same problem? Is your problem solved after replacing the control valve body?
2. Could it simply because of bad transmission fluid? Will bad transmission fluid cause problems in all gears or certain gears only?
3. If it is because of the control valve body, can it cause damage to the transmission itself if not repaired?
4. Is it possible that the control valve body has worn out but there is no code stored?

Thank you,
Zhaoyang
 

·
Registered
Joined
·
6 Posts
My 06 Mazda 6s is slipping when it downshifts to 4th or 5th gear.
It has been over a year since you replaced the valve body. How is it doing? Is it possible just replacing the few quarts of ATF during the change may have been what helped the slip? Or did you try that before the swap?
 

·
Registered
Joined
·
6 Posts
Hello , I have a 2006 Mazda 6 3.0;V6 with automatic 6 speed , and (slap shifter) for the lower optional gears...my car has started to jerk into gears from a stop position when I start accelerating , and clunking loud info reverse . It doesn't do this all the time , it seems it does it after I have been driving the car for about 45 minutes . And , I is not shooting any trouble codes. Does that sound like what yours was doing ? And, since you replaced the control valve body , has it had any more issues , or was that the fix for this problem ? And , how much did this repair cost ? Thank you
I have replaced the control valve body and the car is fine so far.
 

·
Rally Racer
Joined
·
2,526 Posts
Hello , I have a 2006 Mazda 6 3.0;V6 with automatic 6 speed , and (slap shifter) for the lower optional gears...my car has started to jerk into gears from a stop position when I start accelerating , and clunking loud info reverse . It doesn't do this all the time , it seems it does it after I have been driving the car for about 45 minutes . And , I is not shooting any trouble codes. Does that sound like what yours was doing ? And, since you replaced the control valve body , has it had any more issues , or was that the fix for this problem ? And , how much did this repair cost ? Thank you
I would recommend draining and replacing your fluid a couple times. Since you can only drain 1/4 to 1/3 capacity it takes a few drains to renew most of it. If that does not fix it go to the next step.
 
1 - 8 of 8 Posts
Top