Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I went to get in my wifes maz 6 to day and the batt was dead. None of the lights or heated seats or anything was left on. I jumpstarted then car fired up and the horn started sounding, it has never had anti-theft as long as we or the previous owner has had it. She drove it around with alarm sounding til batt charged. The horn would stop sounding or go off every time we shut or opened door. Finally it stopped. She shut car off. Then got in and tried to start engine and it was dead again so obviously something is drawing power when the car is turned off. Does anyone know what could cause this??? What can I do to fix?
 

·
Premium Member
Joined
·
151 Posts
Welcome new member! Take the car to an auto parts store like Advance, Autozone, etc. and they will test the battery for free. Depending on the brand of battery it could already be bad even if it's only a year or two old. These cars electrical systems can act erratically without proper battery voltage. (I assume you've already disconnected any non-factory electrical items like amps, subwoofers, etc. to rule them out as the cause.)
 

·
Super Moderator
Joined
·
16,742 Posts
Welcome new member! Take the car to an auto parts store like Advance, Autozone, etc. and they will test the battery for free. Depending on the brand of battery it could already be bad even if it's only a year or two old. These cars electrical systems can act erratically without proper battery voltage. (I assume you've already disconnected any non-factory electrical items like amps, subwoofers, etc. to rule them out as the cause.)
What he said. The OEM Mazda batteries are junk and you're lucky if you get 2 years out of them. :)
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
3 Participants
Byakuya
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top