Mazda 6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ongoing issue
Mazda 6 sedan (Auto) won’t start every now and then.
When it doesn’t start I have to turn the key and change gears down to Drive and back up to Park. Pull the key out, then put key back in and turn the key. Usually this will fix the issue. If it doesn’t start, I just repeat the process. Usually, it will start after a couple tries. But sometimes it can take hours before it starts again.
The time between reoccurrences can fluctuate as well. Sometimes it can happen multiple times a week, or it won’t happen for a month or months at a time.

Any advice would be greatly appreciated.
 

·
Registered
Joined
·
1,121 Posts
yes, your neutral safety switch is suspect. Check that first. It's possible that it is failing intermittently and is on it's way out. fully.

It's purpose is to allow the engine to start only in Park or Neural position.
 

·
Registered
Joined
·
7 Posts
Ongoing issue
Mazda 6 sedan (Auto) won’t start every now and then.
When it doesn’t start I have to turn the key and change gears down to Drive and back up to Park. Pull the key out, then put key back in and turn the key. Usually this will fix the issue. If it doesn’t start, I just repeat the process. Usually, it will start after a couple tries. But sometimes it can take hours before it starts again.
The time between reoccurrences can fluctuate as well. Sometimes it can happen multiple times a week, or it won’t happen for a month or months at a time.

Any advice would be greatly appreciated.
Could be a few things:
  1. Park sensor as mentioned, though that may be a false indicator.
  2. Ignition relay (there are 2 in the engine fuse box) Mine did this, it showed up as an issue with the security system (flashing key light)
  3. Starter (mine did this too, I did those tricks with the shifter you mentioned thinking it had an effect when it may have just been anecdotal). After a while it got worse and worse until I finally changed it. Not a hard fix at all.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Could be a few things:
  1. Park sensor as mentioned, though that may be a false indicator.
  2. Ignition relay (there are 2 in the engine fuse box) Mine did this, it showed up as an issue with the security system (flashing key light)
  3. Starter (mine did this too, I did those tricks with the shifter you mentioned thinking it had an effect when it may have just been anecdotal). After a while it got worse and worse until I finally changed it. Not a hard fix at all.
Thank you, I shall follow through with your advice and check it out. Appreciate it :)
 
1 - 8 of 8 Posts
Top