Mazda 6 Forums banner

1101 - 1120 of 1308 Posts

·
Registered
Joined
·
145 Posts
If you check the forum, that is really a downgrade. People have reported more issues with the new module.
 

·
Registered
Joined
·
7 Posts
If you check the forum, that is really a downgrade. People have reported more issues with the new module.
It depends. If this is just Mazda passing off the previous module as new then you are correct. I'm hopeful it truly is a new module as Mazda and the dealership are saying.
 

·
Registered
Joined
·
14 Posts
Please let us know the outcome of getting your radio upgraded. I am really only interested in shuffle and not starting USB from the 1st song.

Did you have a BT connection issue, or were your issues with shuffle?
 

·
Registered
Joined
·
7 Posts
Please let us know the outcome of getting your radio upgraded. I am really only interested in shuffle and not starting USB from the 1st song.

Did you have a BT connection issue, or were your issues with shuffle?
I had both problems with USB (starting on the first song every time and shuffle) and issues with bluetooth (not connecting consistently and requiring shutting the car off to reconnect, bluetooth disappearing from the stereo options altogether and random Pandora errors or no song information/control).
 

·
Registered
Joined
·
57 Posts
Nervously waiting for the outcome! IF it turns out to be good I'll head out to the dealership right away.

Hate that my android is not recognized as a USB, it automatically takes my phone OFF shuffle when in bluetooth mode so I manually have to activate it on my device. Takes way too long to connect lol... It is not HORRIBLE but it could be better as an infotainment system, just not acceptable for 2014, maybe for 2004 LOL.
 

·
Registered
Joined
·
14 Posts
I contacted my dealer in NJ. They admitted there were multiple TSBs for the infotainment system, and that they will evaluate the issue and apply the necessary TSBs. I did not get an argument, they admitted there are new TSBs. I have an appointment on Monday, I will post the result.
 

·
Registered
Joined
·
32 Posts
I have a service appointment on Tuesday; I'll ask the service manager about this TSB and whether they have heard about it here.
 

·
Registered
Joined
·
254 Posts
I've contacted Mazda Customer Service in Australia and spoken with my case handler.

He confirmed that there's now a fix for Australian owners. Albeit with conditions. He indicated that the updated module is only support with iPod Nano and Touch devices from 5th generation onwards running the last available software. Also, he indicated that iOS8 is not fully supported on iPhones. I'll take that with a grain of salt though as I know of other people running iOS 8 devices.

As stated somewhere above you only need to contact your service department and explain your situation and they'll order a new module for you.

Hope this helps with the Aussie owners.
Cheers,
Adz.
 

·
Registered
Joined
·
8 Posts
Welp...I JUST (like 4 hrs ago) got home from trying to get this resolved.

I bought the car 3 weeks ago...only found out about the Ipod "Restart from the 1st song every time" issue when i got home with the car and plugged my older Ipod nano 16gb into the USB.

Drove be banana's that every time i started my car i had to start from song one...the loading time was about 45 secs and honestly the loading time I dont care about...its just the "start from" issue that pissed me off.

So i called Mazda (1-800-430-0153) and advised i have researched this issue online and wanted an update. They advised me an update was released and to contact my local dealer.

Contacted local dealer 3/2 and got appointment for 3/6 early AM. I advised the service adviser that i KNEW exactly what was wrong and to replace BT part.

Well after 2.5hr of sitting in waiting room while i thought my BT device was being replaced i was called to the front and advised that they found an issue with my BT device and have ordered the part. (WTF)

sooo...i now need to go back again to get this replaced after i already told them what the issue was.

according to my paperwork it is "TSB09-008/15"

Long rant short...hope by end of next week i can use this "top of the line entertainment system" (per salesman) a little more.
Still hate how you cant adjust mid's in the Bose audio though...just Bass and Highs. dumb.

*Quick EDIT...I know the USB function works in tandem with the BT features. I should add that i am NO WAY using the BT functionality yet...this is ALL about the USB connection with Ipod or thumb drive with MP3's on it
 

·
Registered
Joined
·
324 Posts
Next week i should get the new BT module !
 

·
Registered
Joined
·
324 Posts
I play all my music thru a usb memory stick and also take a couple minutes to load and always start from track ome. Will this update fix this issue too?
it is supposed to fix that problem
 

·
Registered
Joined
·
324 Posts
Look like this TSB is only going to fix the sms problem
 

·
Registered
Joined
·
145 Posts
They clearly don't know what their software is doing. They mentioned 3 and fixed 1 problem. What's the point of mentioning other two ?
 

·
Registered
Joined
·
1,991 Posts
No the TSB writer clearly clearly has ESL grammar issues. They are trying say it will fix all three issues, but the SMS text issue is only fixed for the iPhone.

And march is the time frame that the cx5 message board person had from the response from Mazda corporate when the fix would get rolled out.

Classic. Everybody gives up on the fix then the fix finally comes. Oh well when a few us people receive the new module and report it resolves the issue will be great news for me!
 

·
Registered
Joined
·
173 Posts
Asked my dealer about this, they wouldn't fix it since I am 2500 miles over the warranty. Have to call Mazda Corporate to see if they will help me get this fixed.
 

·
Registered
Joined
·
497 Posts
No the TSB writer clearly clearly has ESL grammar issues. They are trying say it will fix all three issues, but the SMS text issue is only fixed for the iPhone.

And march is the time frame that the cx5 message board person had from the response from Mazda corporate when the fix would get rolled out.

Classic. Everybody gives up on the fix then the fix finally comes. Oh well when a few us people receive the new module and report it resolves the issue will be great news for me!
Asked my dealer about this, they wouldn't fix it since I am 2500 miles over the warranty. Have to call Mazda Corporate to see if they will help me get this fixed.
So if you're out of warranty will they fix the issue? Also, the TSB is supposed to be out now or later on in March and it fixes all the issues especially the loading times issue?
 
1101 - 1120 of 1308 Posts
About this Discussion
1.3K Replies
238 Participants
jsouth
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top