Mazda 6 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter · #1 ·
So, I was driving home for thanksgiving last week and my check engine light came on in my new 2006 speed6. Kinda bugged me the whole way home but oh well, it'll get fixed and it's probably something minor.

Took it into the dealership this morning to get it looked at. After an hour or so they come out to talk to me, and say they aren't quite sure what the problem is but according to the mazda tech line they think it has something to do with the purge valve??? Mazda is recommending that they swap it out, keep it overnight and see if the light comes back on but it might be an problem that pops up here and there.

So now I"m driving a pretty sweet Chrysler Pacifica. It's one hell of a ride, autostick shifting too, think I might trade in the speed6 for one :drive: ha.

Just wondering if anyone else has had experience with this. let a brother know. Thanks guys!
 

·
Registered
Joined
·
875 Posts
So, I was driving home for thanksgiving last week and my check engine light came on in my new 2006 speed6. Kinda bugged me the whole way home but oh well, it'll get fixed and it's probably something minor.

Took it into the dealership this morning to get it looked at. After an hour or so they come out to talk to me, and say they aren't quite sure what the problem is but according to the mazda tech line they think it has something to do with the purge valve??? Mazda is recommending that they swap it out, keep it overnight and see if the light comes back on but it might be an problem that pops up here and there.

So now I"m driving a pretty sweet Chrysler Pacifica. It's one hell of a ride, autostick shifting too, think I might trade in the speed6 for one :drive: ha.

Just wondering if anyone else has had experience with this. let a brother know. Thanks guys!
[/b]
Very common CEL for the MS6. Most people who got it, including me, got it within the first 2000 miles :)
 

·
Registered
Joined
·
6,771 Posts
Hmmm, I think I may have seen someone else mention this problem before. Did you find out the code number from the CEL?
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #4 ·
Hmmm, I think I may have seen someone else mention this problem before. Did you find out the code number from the CEL?
[/b]

Nope, I just brought it in to the dealer and had them look at it, so I'm not sure what the code was.

Rawyzf, what did they end up doing to fix your car and did it permanently fix the problem?

Thanks.
 

·
Registered
Joined
·
875 Posts
Nope, I just brought it in to the dealer and had them look at it, so I'm not sure what the code was.

Rawyzf, what did they end up doing to fix your car and did it permanently fix the problem?

Thanks.
[/b]
Yes, it's been CEL free since then, I am over 9K now. They replaced the purge valve silanoid or something like that. Sorry for the spelling :)
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #6 ·
Yes, it's been CEL free since then, I am over 9K now. They replaced the purge valve silanoid or something like that. Sorry for the spelling :)
[/b]
Well let's hope that does the trick then, and hope it's quick cause this pacifica sucks, a lot.

haha, no prob, it's amazing how difficult spelling is when you don't have the all mighty microsoft there to underline in red and suggest different spellings.

by the way, is the yzf from your name due to Yamaha motorcycles?
 

·
Registered
Joined
·
979 Posts
I am CEL free none at all, I am at almost 23K miles
 

·
Registered
Joined
·
875 Posts
Well let's hope that does the trick then, and hope it's quick cause this pacifica sucks, a lot.

haha, no prob, it's amazing how difficult spelling is when you don't have the all mighty microsoft there to underline in red and suggest different spellings.

by the way, is the yzf from your name due to Yamaha motorcycles?
[/b]
Yeah, I need spell check on here like in Outlook and Word ;).

Yes, you are correct. Raw is my initials and the YZF was the bike I used to have.

I had a 93 FZR 600 and a 94 YZF 750. That was a bad bike back in its day :)

-Ryan

I am CEL free none at all, I am at almost 23K miles
[/b]
Lucky you!
 

·
Registered
Joined
·
176 Posts
Just wondering if anyone else has had experience with this. let a brother know. Thanks guys!
[/b]
The issue is not uncommon and has been discussed on the forum several times. Your problem is probably the evaporation system solenoid purge valve. It is part of the system that absorbs fumes as your fuel system breathes and then controls burning those same absorbed fumes while the engine is running. If the valve goes bad, your emissions control system thinks that your gas cap is not properly tightened and throws a CEL. I had the problem, and was given a loaner just like you. The problem was fixed and never returned. My first CEL (they just reset it) was at about 1700 miles, and the repair at about 2500 miles. You should be fine.
:drive:
 

·
Registered
Joined
·
693 Posts
I took mine in at 875 miles for the purge valve also and i got to drive a mazdaspeed protege but again i guess its cause the service advisor is my uncle lol :nana:
 
1 - 11 of 11 Posts
Top